Back to overview
Downtime

Undergoing security update that might cause some downtime

Apr 07 at 01:30pm CEST
Affected services
api.spaceinvoices.com
Admin panel
Web App

Resolved
Apr 07 at 01:43pm CEST

The security update was successful and operation of all systems was restored

Created
Apr 07 at 01:30pm CEST

Undergoing security update that might cause some downtime