Back to overview
Downtime

Experiencing issues with queuing system

Nov 19 at 08:45am CET
Affected services
api.spaceinvoices.com
Admin panel
Web App

Resolved
Nov 19 at 10:22am CET

We have deployed a fix and are restarting the servers, which might take a bit to stabilize.

Thank you for your patience.

Updated
Nov 19 at 08:49am CET

We have identified the issue and are applying the fix.

Created
Nov 19 at 08:45am CET

Experiencing issues with queuing system, we are actively investigating.